PDA

View Full Version : Toyota engine help



spkrman15
04-09-2006, 06:19 PM
I have a toyota Rav 4. It has a 2.0 L engine. I am having trouble with oil leaking into the spark plug tubes. I have changed the valve cover gasket and the spark plug seals.

Any ideas on how the oil is getting in? I am thinking there might be a hole in the tube or oil is leaking in through, where the tube and the cylinder head meet.

Here is hoping!!!

Rob :)

Joel
04-09-2006, 11:25 PM
Is your crankcase ventilation system working properly? Internal pressure will sure encourage leakage.

Other than that, good gaskets/seals, clean sealing surfaces and proper torque is all that is generally required for a leak free valve cover.
OTOH, I know nothing about your particular engine.

darryl
04-10-2006, 02:58 AM
I've seen many cases where a leak is from over-tightening valve cover bolts. Sometimes the mating surface needs to be knocked back where the bolt holes are. Don't know about that particular engine.

lbhgti
04-12-2006, 03:22 AM
Your RAV4 has the 3SFE engine. The valve cover gasket and those round seal washers under the nuts have nothing to do with oil leaking into the spark plug tubes. The tubes are threaded into the cylinder head, and sealed from the factory with a threadlocker type sealer. Over time, they start to leak. The cure is to unscrew the tubes, wirewheel the threads on the tubes, coat with fresh sealer (the black toyota FIPG (form-in-place-gasket) silicone is the best I've found, but its around $20 a tube....well worth it though) and reinstall. I give the threads in the head a quick shot with brake cleaner and compressed air, but I've never had a problem with them not being clean upon reassembly. There is a special tool, like an inside pipe wrench that is used for removing the tubes without damaging them. I happen to have one of these tools (I was a mechanic for toyota until about 2 years ago) and would be willing to loan it to you if you pay for shipping and leave me a $50 paypal deposit, refundable as soon as I get the tool back. Let me know.

You can email me: pat@stopitbrakes.com

MOTODAD
04-12-2006, 12:02 PM
I second this repair. I work on a lot of toyotas and this works.

spkrman15
04-12-2006, 05:57 PM
Hey Great guys. I was sure it was something other then my vavle covers but as i have learnt over the years, is try what you know and then try what you don't know!

Rob :)