PDA

View Full Version : OT- Networking two computers. Need help



JRouche
06-22-2008, 02:43 AM
Ok.. I have had nothing but problems trying to sync up two computers.

I have them both on a common modem for the internet access. Both hooked up to the modem through NIC cards. Both have software firewalls but I even stopped the firewalls for troubleshooting.

They are Win XP pro on both boxes. I have went through ALL the "setting up networks" processes for both. I have set each one up with individual computer names, but similar.

I have shared the folders and set permissions. Being XP pro (NTFS) I can set the permissions even tighter, or more relaxed.

Ok.. My problem. I can see one of the boxes under windows explorer or "My network places". And I can see it and get to the first level of folders but it wont let me go beyond that first folder. I think I see why, cause it is using the "simple share" permissions instead of the NTFS "user permissions". I can get through that.

The thing that is baffling me is... One box cant even see the shares from the other box, wont even post them up. And the other sees the shares but limits me to just seeing them (permissions issue Im thinking).

The box that wont even see the shared folders knows there is another computer there (on the workgroup) cause when I go to "view workgroup computers" it lists it as part of the workgroup. So it sees the computer, but wont publish the drives.

Now, I can set the "everyone" permission under the NTFS permissions not the "sharing permissions" (different you know) to what I need, basically all functions, like admin privileges but I dont know if thats all that secure.

When I set "everyone" to admin control I can access all the files on the one box.. I can have my firewall up and still have access with "everyone" but I dont think thats a good method, with setting "everyone" with full control..

And long story longer... What I think I should be able to do is set up both computers with a "User" account that has access (with a password cause of XP pro) and set permissions just for that "user" Meaning, can I set full access for User X and keep all the other permissions the same?

I made users on each box and I cant figure out how to remotely log into the "server" with this user.

And if so how?? I have each computer named differently, lets say A and B. I have placed the user of each computer on both. Can I do what Im trying to do?

Sure, I can go easy and set "everyone" at full access. But am I still protected? My firewall is tight, I think, its stealth. Want my IP, all you get is the same ol Verizon info and my browser info, no open ports to be seen..

Ok, Im at a loss here. I just want to transfer files from one box to another through the "shared folders" system. Nothing that many of you guys dont already do.. With a lil security..

Any help?? Thanks guys :) JR

Evan
06-22-2008, 05:27 AM
Check the MAC address of each computer and verify that it isn't the same. I have seen similar problems caused by two computers having the same default MAC address assigned to each by the onboard NIC.

DENedbalek
06-22-2008, 08:04 AM
JR I had similar problems getting a couple of machines to talk to each other. It was finally solved by making sure that the USER accounts were the same on both boxes with the same PASSWORDs. Suddenly, after a reboot on both, the sharing worked as expected. You seem to be a more advanced computer user than I so you have already tried this. Good luck.

Dwayne

JoeFin
06-22-2008, 08:09 AM
Ok.. I have had nothing but problems trying to sync up two computers.

I have them both on a common modem for the internet access. Both hooked up to the modem through NIC cards.

I've seen this done through "Shared connection" but it is not really a "Home Network" per say

Just end your misery and go down and get a "Linksys" router/digital switch(Cisco's off shore brand) for about $50. Your computer will actually see Faster internet speeds as well as have a true subnet mask protocol that will make all this networking child's play

GadgetBuilder
06-22-2008, 10:51 AM
You didn't indicate the type of modem but if it is broadband, a router is a simple way to go and provides a firewall in the bargain. I got a used Netgear FVS318 on eBay for $25 delivered and it works well and is easy to set up. Setup is done using your browser and includes extensive help so it is (dare I say) fairly intuitive :D

Setup of MS networking is partly magic but clearly it was written by a very competent programmer so once set up it works very well. Unfortunately it is complicated to set up for those of us who don't do this every day.

The following site was helpful in getting my setup working properly because it walked me through the complete process step by step:
http://www.homenethelp.com/web/howto/net.asp

John

b2u44
06-22-2008, 11:37 AM
I have never been able to get "My Network Places" to work consistently. Instead, if I want to share folders between computers, I setup "Network Drives." They show up in "My Computer" just like the A:\, C:\ drives, etc.

It sounds like you've already got a handle on setting folder permissions. I recommend that you always password-protect the shared folders to keep unwelcomed eyes out of them.

There are numerous websites that discuss how to share and map network drives. One is:

http://www.drbillbailey.net/share.html

Please note that the website uses a cross-over cable instead of a router, but you can ignore that and just use your router as normal, while following the rest of the directions. Also, you shouldn't share the entier C:\ drive like the webpage's author did -- it's a big security risk.

As a final note on network drives, most tutorials say to map an address like:

\\machine-name\share-name

If your computer was named "MyComp" and the shared folder was "Documents," then you would map:

\\MyComp\Documents

Sometimes, windows networking is unable to figure out what "MyComp" is, so I've found that a much more reliable alternate is to use the IP address that is assigned to "MyComp" by your router. For example, the IP address is probably something like 192.168.1.100. If that's the case, you would map

\\192.168.1.100\Documents

I hope this helps. Windows networking is always a bit tricky to setup, but once you get it setup, it usually works quite well.

Edit/Addition:

When you enter your username and password to access the remote folder, you can't just type the username. Instead, you must type "computer_name/username." For example, if the remote computer is called "MyComp" and the username is "MyName", then you would use:

MyComp/MyName

The password will be MyName's password on the REMOTE computer.

JRouche
06-22-2008, 09:50 PM
Check the MAC address of each computer and verify that it isn't the same. I have seen similar problems caused by two computers having the same default MAC address assigned to each by the onboard NIC.

Ok, Evan, Ill check that but I dont think they are gonna be close. Seeing how the old computer is five plus years old and has a NIC and the new one is a chip set on the MB.. Thanks!!! JR

JRouche
06-22-2008, 09:51 PM
JR I had similar problems getting a couple of machines to talk to each other. It was finally solved by making sure that the USER accounts were the same on both boxes with the same PASSWORDs. Suddenly, after a reboot on both, the sharing worked as expected. You seem to be a more advanced computer user than I so you have already tried this. Good luck.
Dwayne

I made the "User" accounts the same, easy to do with them side by side, still no luck. Thanks... JR

JRouche
06-22-2008, 10:00 PM
I've seen this done through "Shared connection" but it is not really a "Home Network" per say

Yeah, I mis-spoke. Not a HN, just trying to share with some security.. And I have linked up two boxes before via NICs but Im not looking to spend any money on the old box. I just wanna move the 120gig of info over before I wipe it and give it to my kids :) Guess I might just disconnect the internet cable and give the "everyone" account full access and be done. It was just driving me crazy why I couldn't set these guys up to talk. Im not all that computer literate but this is supposed to be a simple function with XP and Im thinking if I cant do it I must be a real moron. So I keep pluggin at the problem, not that it will cure my moron status LOL... Thanks, JR..

JRouche
06-22-2008, 10:01 PM
You didn't indicate the type of modem but if it is broadband,

It is broadband, would that matter???

JRouche
06-22-2008, 10:09 PM
There are numerous websites that discuss how to share and map network drives. One is:

http://www.drbillbailey.net/share.html


Thanks, Ill check them out




As a final note on network drives, most tutorials say to map an address like:.... I've found that a much more reliable alternate is to use the IP address that is assigned to "MyComp" by your router.

Yeah, I cant gain access trying to map the drive, wont see it. And Ill try using the IP but I dont think its gonna see it. Thanks. JR

JRouche
06-22-2008, 10:13 PM
Just end your misery and go down and get a "Linksys" router/digital switch(Cisco's off shore brand) for about $50. Your computer will actually see Faster internet speeds

Oh yeah, the internet speed is fine, got a verizon fiber optic with a 20mbps/5mbps connect and it doesnt seem all that slow :) Thanks, JR..

b2u44
06-22-2008, 11:21 PM
What software firewall are you using? I've always had to give the software firewall a "white list" of IP addresses corresponding to the computers that should be allowed to access the shared folders. Typically, the IP addresses should be between:

192.168.1.100 - 192.168.1.255

Most local networks use that range of IP addresses, but I guess yours might be different.

Evan
06-23-2008, 01:06 AM
Power up both machines in safe mode with networking and see what happens. If it works you have a software issue.

GadgetBuilder
06-23-2008, 02:31 PM
It is broadband, would that matter???


I'm not familiar enough with dial-up to know whether it uses the same type routers. The only routers I've used have connectors compatible with broadband modems.

I had some issues initially establishing connections between our two computers, even using the router. I shut down the software firewall in both machines to verify the firewalls were the problem, then turned one firewall on and fiddled its permissions and once that was working I turned the second machine's firewall on and tweaked it similarly. The router's firewall protects the machines well so there is little chance of getting hacked while making the software firewalls behave. The site I mentioned previously was very helpful in getting the comm system set to connect the local computers as well as be reasonably secure.

The FVS318 router was helpful because it is easily configured via the browser and has extensive help. One nice feature is it shows the attached devices by their assigned name and lists their IP address (generally 192.168. etc.) along with their MAC addresses - most all the info needed for setup.

John

ckelloug
06-23-2008, 09:58 PM
If you're trying to hardwire connect two machines via their ethernet ports, you need a crossover cable if there isn't a switch or hub between them.

JRouche
06-23-2008, 11:31 PM
What software firewall are you using? I've always had to give the software firewall a "white list" of IP addresses corresponding to the computers that should be allowed to access the shared folders. Typically, the IP addresses should be between:192.168.1.100 - 192.168.1.255
Most local networks use that range of IP addresses, but I guess yours might be different.

Hi, I have set up each firewall to allow the IPs. But just during troubleshooting I axed them, they are off. Thanks, JR

JRouche
06-23-2008, 11:32 PM
Power up both machines in safe mode with networking and see what happens. If it works you have a software issue.

Just tried it, same scenario as when all the software was up and running as in a normal boot. Thanks, JR

JRouche
06-23-2008, 11:36 PM
I had some issues initially establishing connections between our two computers, even using the router. I shut down the software firewall in both machines to verify the firewalls were the problem,

The FVS318 router was helpful because it is easily configured via the browser and has extensive help. One nice feature is it shows the attached devices by their assigned name and lists their IP address (generally 192.168. etc.) along with their MAC addresses - most all the info needed for setup.

John

Firewalls are off, really off.. :)
This BIG actiontec modem is similar. I can go in and see all the devices. Including two TV boxes (FiOS TV). Yeah, it assigns MAC addresses to those also. And I say big cause it is. But no, all those settings are good.. Thanks, JR

JRouche
06-23-2008, 11:41 PM
It really has to be something I am doing wrong. Cause like I said before. If I set the EVERYONE group to have full privileges then I can communicate between the computers. Thats why I was asking about some permissions setups. Theres no way Im running with EVERYONE set like an ADMINISTRATOR group.

Anyway, Ill keep plugging along. Thanks for all the help and if you have any ideas Im all EARS :) JR

JRouche
06-23-2008, 11:45 PM
If you're trying to hardwire connect two machines via their ethernet ports, you need a crossover cable if there isn't a switch or hub between them.

Nope, been there done that. Still have a crossover cable for years back. Actually have a lap link cable too. And a linking USB cable (slow).. No... I have done those things but I dont have extra NICs in these so thats out. And really, I just wanna share these darn folders as its supposed to be done...
Thanks, JR

dp
06-24-2008, 12:27 AM
On both systems open a command line window and type:

ipconfig /all

then verify that they are in the same network space. Both should have identical netmasks, and the first three IP address triplets should be the same.

For example:

IP address: 192.168.1.10
Netmask: 255.255.255.0
Broadcast: 192.168.1.255

Default router should be the same as the IP address. Using the example: Default router 192.168.1.10

On the second box the IP address and default router should be the same though different from above in the final triplet, and the netmask should be identical.

On either box you should be able to ping the other in a command line window: ping 192.168.1.10, for example. If this doesn't work then nothing will work.

Then identify the workgroup each system is in. It can be anything you want so long as both are in that same group.

Ensure sharing is enabled on both systems.

If these are the only systems on the network then DNS won't work. Windows networking will work though as it uses a broadcast to identify the servers. The broadcast mask should be correct on both systems.

b2u44
06-24-2008, 12:54 AM
I assume you have disabled "Use simple file sharing" in the Folder Options dialog box. If so, that's good.

Because your file-sharing works fine if "everyone" is given permission, the problem is not with your network. I am 99% sure that the problem is simply with how the permissions are being established.

Remove "Everyone" from the "Group or user names" field in the "permissions" dialog window. Then add a user, making sure to click the "check names" button after typing the desired username in the "Enter the object names to select" window. After clicking "check names," the name should be of the format:

ComputerName\UserName

Make note of that entire name because that will be the "username" that you enter on the other computer when trying to map the network drive. For now, restrict the permissions for that username to "read" only. Do not "deny" anything.

On the 2nd computer, open the "Map Network Drive" window. In the "Folder:" field, enter the IP address of the first computer followed by the "Share name" of the shared folder on the first computer. Then, click "different user name." Enter the "username" that you recorded earlier, followed by the password for that username on the first computer. This should result in a properly working shared folder, where you can read the shared data on the 2nd computer. Of course, you can always give "write" access to that folder too.

In hopes of avoiding any confusion caused by the wording in the previous paragraphs, I will quickly repeat my instructions while substituting fictious usernames, passwords, etc.

The first computer:
Computer Name: BobComp
Computer IP: 192.168.1.101
Username: Bob
Bob's Password: Bob234
Shared Folder's "share name": MyFolder


On the first computer, give "read" (and possibly "change") permissions to "BobComp\Bob"

On the second computer, map a network drive to:

\\192.168.1.101\MyFolder

In the "different user name" dialog, type "BobComp\Bob" as the username, and "Bob234" as the password.

As a final note: please restart both computers before trying this. Windows has a nasty habbit of not releasing connections (even bad connections) to shared folders, leading to huge headaches when trying to establish networking.

Hopefully this can help a bit. Let us know how things work out.

JRouche
06-24-2008, 02:14 AM
On both systems open a command line .........


Yup, everything you wrote is the right info.... The boxes are set up on the system correctly, all with the right IPs and subnet. Not of any doing of my own, the modem dished out the right numbers. :)

No, see, I think its a permissions issue. Again, I can have the boxes talk when I give full permissions through an "open" EVERYONE group. But thats not a good idea to use that.

Even with EVERYONE locked up as it should be I can still see each computer on the workgroup under "My network places". Meaning both computers are listed but if I select the other computer I get an error message saying I dont have permission and contact the admin.. Bla bla bla...

To me, and I dont know anything about these things really, but it appears like a simple permissions issue. I cant figure it out and I have spent so much time looking at each setting. I have both side by side so that makes it easier..

What blows me away is this is supposed to be a simple function under windows to share files and folders. Im not trying to network them or anything, just a share..

And really, I have never been able to get a good share with any of my computers, even in the past, like fifteen years ago. Thats why I have all these cross cables, lap link cables and software, and everything else. I actually still have a cross cable for the parallel port for back many years ago when I was going through the same issue.. I know its me, has to be. I know there has to be alot of you guys using the share function of windows.. Frustration to say the least. Thanks for the help, JR

JRouche
06-24-2008, 02:21 AM
A hugh amount of good information......

Ok, thats what I was looking for. A "Sharing for dummies" tutorial.. Really what I was hoping to see..

Im going to follow all your instructions tomorrow.. I like it and Im hopeful. You gave alot of good steps to take and Ill go through the entire process.. Ill letcha know how it goes.. Thanks! JR

Metalmelter
06-24-2008, 08:33 AM
JRouche,

I've had my nightmares with XP Pro just as well. A great OP system but it leaves a bit to be desired in the networking area. I don't have my home pc in front of me so I'll have to go from memory... lol

I was getting the darned "You don't have permission to access this computer" error message no matter which way I set up the network and from whatever PC I was sitting at (and there are four). I tried to find the exact site I googled to but can't.

It seems that MANY people are having the same issues, and the end result was to install (a missing?) internet protocol in the network properties on all the machines. It's one of the protocols that would normally be there on the earlier windows OP systems, but XP Pro for some reason does not install it automatically. Once that was done - ALL problems were solved. My issues were the same or similar as yours - I could see the other pc on the network but could not talk to it. The router was not the issue. If I recall correctly, it was a NETBIOS over TCP/IP protocol that needs to be installed. Keep in mind even if you install it, it won't harm your machine. If anything, it would only add a very minute amount of processing time (you probably won't even notice it). I'll paste here the sites I'm looking at as I hunt for this issue again:

http://www.trap17.com/forums/networking-windows-xp-pro-other-windows-version-t47039.html

http://www.howtofixcomputers.com/forums/xp-networking/access-denied-85957.html

http://www.pctools.com/forum/showthread.php?t=33684&page=2

There are many more sites but I think you'll get the idea... ;)



Let us know how you do!


Eric

JRouche
06-25-2008, 12:10 AM
Ok guy.. Thanks for ALL your help..

I got both boxes talking with each other, even included the wireless laptop to join the show..

I tried everything explained here and it was all good info. Perfect. Boiled down to being a few different problems. One was the router itself.. I had to go into it and change some setting, an endless ammount settings available there. Another was an old network chipset on the motherboard of the "old" computer was playing havoc with the networking, even though it was disabled. Another was the firewall on the new computer, Outpost, great firewall but the new version I bought wants to tie into the networking functions and without it active but still part of the configuration it was disabling some functions. Another was the "user" and passwords which is something I screwed up when I created a new user account on the new computer to match the old one..

But I got them and happy and communicating, even the laptop, thanks to ALL your help.. Thanks abunch...JR

b2u44
06-25-2008, 09:37 PM
Glad you got it to work.