PDA

View Full Version : Kool Mist issues



mechanicalmagic
07-13-2009, 11:14 PM
I've used Kool Mist at work for a couple decades. These units are in operation a LOT. So, I got one for home use about 10 years ago. Everything was fine for many years, BUT for the last few years, it has been a PITA.

It clogs up with some sot of blue crap, semi solid, in the Blue block. I'm using genuine 77 from Kool Mist, mixed a little strong. It only gets solids in the Aluminum block, where the coolant flows. I've added a filter from the tank, no help. I'm not talking a year here, I cleaned the darned thing out a week ago, and it was totally plugged today. The Aluminum in the Anodized block is horribly pitted (coolant side). The Brass parts show some build-up but no real stuck stuff.

I called Cool Mist in CA, and got one of their front line folks that told me it should be cleaned and flushed every night, and that otherwise it would rust. You can guess my opinion of her technical expertise.

So, any suggestions?

I plan to make a Lexan block, made the dwg today, it won't corrode, and maybe I can make it clear enough to see the crap.

Dave J.

Boucher
07-13-2009, 11:50 PM
I got mine second hand from an old shop. The block is some kind of plastic (maybe Delrin). They may have re-done it. It goes unused for long periods and has never given me any problem. The tank is coming apart and I was cleaning it up. The screen over the intake line has disentigrated to the point that It was going to suck up something and stop things up. I have never used Lexan.