PDA

View Full Version : O/T Isuzu 6sa1T Truck Engine



wbleeker
06-04-2010, 05:05 AM
Has anyone had any experience with these? We bought the truck new in 1989, used it till around five years ago, when I noticed oil in the water and it needed a new roof and some other panels. The panels and paint are done and I have replaced oil cooler gaskets, pressure tested the oil cooler, replaced the water pump gasket because there is an oil gallery behind it, washed out the radiator and block with degreaser, put clean water in it for a test and run the engine numerous times,with no oil. Today I drove the truck about eight kilometres, and got the engine up to temperature by the time I got it into my workshop it had oil in the water again! I have a compressor kit to put in over the weekend but am running out of places to look, engine performance is normal. Any suggestions?
Will

Bguns
06-04-2010, 05:13 AM
I have worked on bigger Izuzu's

Sounds like head gasket, a crack in head, or if a wet liner engine, liner seals...

If running straight water... cavitation damage to block or liners possible too...

Not what you wanted to hear, I'm sure...

wbleeker
06-04-2010, 05:30 AM
Its a dry sleeve motor, it has always had corrosion inhibitor in it the straight water is just for a test. I am off to Africa, Amsterdam and Hong Kong next week I might worry about it when I get home.
Will

Bguns
06-04-2010, 05:40 AM
Some Cummins engines require a anticavitation additive.

Anti corrosion does not always equal anti cav...

Isuzu recommends low silicate coolant: http://www.astm.org/Standards/D4985.htm

The shock of the cylinder firing, causes bubbles that actually erode the liner or block.

I have seen ~3/8 in thick liners pitted through by this...

Also seen on Cat engine blocks run on straight water.

After only 8 Km test, I would look at the head gasket/head first