PDA

View Full Version : Restoring my Benchmaster Vertical Mill #MV-1



JSchulte38
11-30-2003, 04:36 PM
Hi Guys,
Just thought I would say I am having a great time and a uplifting experience (like a kid with his first new bike) as I clean and restore my Benchmaster Vertical Mill. Being retired I can't wait each day to get out into the garage to do a little bit more restoration. I've replaced the pulleys, motor, drawbar, V Belt and added more MT-2 X 3/8X16 drawbar tooling.

I would like to ask how I adjust the lead screws to eliminate the play in the lead screw and bronze nut. There is an adjustable collar with a set screw for this purpose but I'm out of adjustment on my machine. Where do I put a bushing to regain some adjustment back? Any one got some ideas for me. Would certainly appreciate any info.

Joe Schulte
Northern New Jersey

docsteve66
11-30-2003, 11:59 PM
Welcome . The adjustment varies from lathe to lath- tell some specifics about yours.

edit comment: I meant machine to machine.

[This message has been edited by docsteve66 (edited 11-30-2003).]

Thrud
12-01-2003, 01:59 AM
Joe
First thing you need to check is if the lead screws move in their mounts. If they do you should consider some way to reduce play. I did this on my lathe by installing double row annular ball bearings at one end of my lead screw - this eliminated all slop in the lead screw, leaving the play in the half nuts to contend with. In your case your mill may have a preload or anti-backlash adjustment (normally a spring arrangement on the nuts) or it may just be worn and require rebuilding. Bronze nuts are easy enough to machine. You might be able to repair your old nuts with a product called moglice http://www.moglice.com/

[This message has been edited by Thrud (edited 12-01-2003).]