Results 1 to 10 of 10

Thread: wico model x magneto problems

  1. #1

    Default wico model x magneto problems

    I have an old Oliver HG crawler tractor with 4 cylinder engine I usually keep in a warm garage. At times I have to move it outside but usually get it back inside in several hours and keep it covered when out. Recently I had to keep it outside overnight but covered. When I went to start it no spark. I usually have to take the magneto apart and clean the points to get it to start. Does anyone have anyways to keep the magneto in a starting condition? I have the magneto covered with a piece of rubber inner tube in addition to the tarp. Thanks Paul

  2. #2
    Join Date
    Nov 2002
    Location
    Maine
    Posts
    1,439

    Default

    Moisture issue perhaps? Maybe a cracked cap?

  3. #3
    Join Date
    Aug 2006
    Location
    Taylorsville Ky
    Posts
    5,882

    Default

    I don't think the points are getting dirty, I think the coil or distributor cap may be bad. Bad insulation on the coil can let it leak to ground. If the distributor cap is cracked it can leak to ground. If there is no spark at any of the four wires I would suspect the coil.
    It's only ink and paper

  4. #4
    Join Date
    Mar 2005
    Location
    Palmer Alaska
    Posts
    748

    Default Having 15 or 20 Magneto Sparked rigs around....

    It is Moisture on Points..., Mags cannot tolerate any Contamination on the Points... None, Nada, Zip, etc..

    The Cover on Warm engine Might be causing the condensation.., (Neighbor has an HG and an OC3) dry points out before starting. Fairly easy to get to on lower right front of Tractor...

    The WICO X has a Window for timing mark, and is less than a Moisture proof design.

    A Oil change can help.... if you have moisture/water in engine, when engine gets up to temp, Steam rises and gets into Mag...
    Last edited by Bguns; 03-13-2009 at 06:04 AM.

  5. #5
    Join Date
    Apr 2007
    Location
    South Texas
    Posts
    746

    Default Have you replaced the wire?

    I have replaced the wire between the points and the coil with a "modern" vinyl insulated wire. Several mags i have dealt with had the old cloth insulated wire which absorbs moisture and functions as a pretty good short. By doing so I went from a fussy mag to one with a good hot spark every time. May not be authentic, but is was reliable.

  6. #6
    Join Date
    Aug 2006
    Location
    Taylorsville Ky
    Posts
    5,882

    Default

    Moisture in a mag. is bad and yes, wet points is bad. If he runs a paper match between the points and trys it and it works the moisture at the points is a problem. If drying the points don't give a spark then the coil or cap is at fault.
    It's only ink and paper

  7. #7
    Join Date
    Mar 2008
    Location
    Vermont
    Posts
    641

    Default

    I've had this problem for years with the Fairbanks-Morse magneto on my big old Kut-Kwick mower. Two things: first, it seems that once the points have corroded, they will corrode more readily the next time, no matter how clean you get them. I have no answer for why this is. Second, make sure the innards of the mag are very dry, and then if there is no gasket on the magneto cover, try to fit one, even if there wasn't one before. The F-M was originally intended to have a thin paper gasket, and these are often lost and left out, but if the magneto cover warps even a tiny bit, it's enough to cause problems.

  8. #8
    Join Date
    Jul 2003
    Location
    Southern Oregon
    Posts
    597

    Default Magneto repair

    Hi
    Years ago I used to repair magnetos and the major problem I found was that the ground between the laminated iron core for the coil and ground was a poor connection. Many times just breaking loose the coil mounting screws and re tightening them corrected the problem. As far as moisture, ventilation inside of magneto is very important.
    Yankee1

  9. #9

    Default magneto problems

    Well it's been 4 days that crawler set outside. It warmed up to 40 degrees today,went out and it started!! I was thinking of possibly blowing hot air into the magneto through the inspection window from a hair dryer if it had not started. Thanks for the valuable responses. Now to figure out how the governor works. Paul

  10. #10
    Join Date
    Aug 2003
    Location
    Nazareth, PA
    Posts
    2,399

    Talking

    Quote Originally Posted by spinrow
    I have an old Oliver HG crawler tractor with 4 cylinder engine ...
    Thanks Paul
    now COME ON!!!!! you can't make a post like this without photos.

    i have a '56 OC-46 crawler (son of the HG series). the mag was replaced with a distributor, and while it does work okay, i really would like to someday convert it back to a mag. i think i have enough parts to make one good mag.

    andy b.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •