Announcement

Collapse
No announcement yet.

Way OT, Diagnostic Trouble Codes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Way OT, Diagnostic Trouble Codes

    I have a 2000, Ford 7.3L PowerStroke Diesel. I've changed the factory programing with a Hypertech Programer. Yesterday I pulled down an error code PFFFA! The truck will start and then quit, but after a bit will start and run fine. Had this problem back when the truck was new and it was the CPS that was the problem, but didn't have a code reader at the time.

    Despite my research, I can't find any corresponding DTC anywhere. Does anyone have any thoughts/ideas on this. I strongly suspect it's the CPS that is the culprit based on the behavior of the vehicle.

    Any thoughts are greatly appreciated.

    John B

    [This message has been edited by jr45acp (edited 06-12-2005).]
    John B

  • #2
    Have you disconnected the battery for longer than 1 minute? If you have, have you gone through the start up proceedure where you run the engine at about 1500 rpm for about 15 seconds and then accelerate it .
    In order to reset the cars computer.
    Also on Ford the throttle has to be accelerated to maximum once to allow the computer to adjust for elevation of the vehicle so that the fuel mixtures are correct. If this has been done, try consulting a manual called a "K" manual from Ford for that specific engine. Or call Ford for the trouble code list. Thats
    all I can think of at the moment. I've been
    retired since 1996 . Good Luck.

    Comment


    • #3
      Hi Again,
      Got to thinking in as much as only the first digit in that trouble code indicates anything P= powertrain That it is possible that the new programming is blocking the correct codes from reading. May have to go back to old programming, then scan for codes, repair if applicable. Then if when reintoducing new programming if trouble reoccurs we will know its in the new programming.

      Comment


      • #4
        The codes are numerical.
        P0 is a generic (for smog) P1 is manufacturer
        specific.
        To clear codes, remove fuse #15 for a few minutes.Under dash, not under hood.(CJB)
        CPS failure may or may not set a code.
        The symptoms are many and varied, added at no extra cost by Navistar, solely to amuse the owner.
        Diesel uses MAP senser,(measuring turbo boost) no need to stomp throttle for altitude change.
        Revert to stock and see wha' happens.
        Might try this site, many knowledge people hang out there.
        http://forums.thedieselstop.com/ubbthreads/

        That code may signify the reader is ill.
        Check the power port fuse, this powers the OBD plug.(but, unless reader has an internal battery, there would not be any readout)
        I have the codes, and shop manuals, if you need something looked up.


        [This message has been edited by PSD KEN (edited 06-12-2005).]

        [This message has been edited by PSD KEN (edited 06-12-2005).]

        [This message has been edited by PSD KEN (edited 06-12-2005).]

        Comment


        • #5
          Ken, I returned the vehicle to the factory programing and it started and ran fine, for about 10 minutes then shut down. I again pulled down the same code previously mentioned. I had the same symptoms a couple of years back and it was the CPs and a stronly inclined to believe it is a repeat of this.

          John B

          Edit: Ken can you check to see if you have a PFFFA code in your reference materials?

          [This message has been edited by jr45acp (edited 06-13-2005).]
          John B

          Comment


          • #6
            UPDATE!!!!!!

            I talked with Hypertech and the code(s) are merely "glitch" codes. My diesel mechanic agrees and it appears my symtoms are a result of the CPM failing.

            Guess Navistar put those in just to keep life interesting.

            John B
            John B

            Comment


            • #7
              I don't have a lot of faith in the OBDC codes. On my PT Cruiser it is simple to read the codes. Just press the trip meter reset button while turning on the ignition and it goes through a diagnostic and then displays any codes on the odometer readout. But, it doesn't work very well. A chipmunk knawed through one of my plug wires a while ago and the engine was missing occasionally on that cylinder. There are about four different codes that should have appeared including one for engine missing on cylinder #1 as well as exhaust too rich. Nothing ever showed up. The mechanic at the dealership couldn't explain it.
              Free software for calculating bolt circles and similar: Click Here

              Comment


              • #8
                Yup, knew that was not a genuwine DTC.
                As I stated, the CPS failure symptoms are many and varied, solely for your entertainment.
                I carry spare in the truck.
                The codes are not a find all/be all curing device, they usually only point you in the right direction.
                Per the plug wire, a visual inspection is a good starting point, what has broken, fallen, etc.
                I got my share of ate (automatic test equipment) in avionics.

                [This message has been edited by PSD KEN (edited 06-13-2005).]

                Comment

                Working...
                X