No announcement yet.

XP re-revisited

  • Filter
  • Time
  • Show
Clear All
new posts

  • XP re-revisited

    I got that prog..... What it apparently does is nearly instantly generate lots of megabytes of data on what has been going on. Way too much to deal with, actually..... Nothing glaring showed up in what I waded thru.

    First clue..... when that program is running, the system REALLY slows down and gets floaty.....

    Second.... Somewhere or another the memory in this machine turned out to be 1 gB, not 2 gB.

    third.... the virtual memory was set to size from 1.5 to 3 gB.......

    Four, I changed the virtual memory to half that, and so far it has been considerably better.

    Don't know for sure, since the effect seems to be soemwhat dependent on "system history"...... the more that HAS been done, the slower the response gets. Since I had to reboot to change settings, who knows.

    Memory leaks pushing more into VM? Dunno yet.

    Keep eye on ball.
    Hashim Khan

  • #2

    Somewhere, there is a registry hack to keep the 'system' in memory, often the os will sometimes swap parts to disk memory, which causes seriious slowdowns.

    After going this long without using XP, I finally ran into a few progs that NEED XP, so broke down and installed it, my system seems to like it a bit better, but it's all new, dual core, 1gig etc,and so far it's -almost- as good as win2k, occasional glitches that pause right in the middle of stuff, still hate xp.



    • #3
      First, if the system has a second physical hard drive set a paging file on the second drive. Then reduce the size of the paging file on c drive to a very small amount, maybe 10 megs. Don't disable it.

      If you don't have another physical drive then try letting Windows manage the paging file instead of setting the size.
      Free software for calculating bolt circles and similar: Click Here


      • #4
        "Somewhere, there is a registry hack to keep the 'system' in memory"

        I think this is the procedure.

        "Windows designates a portion of hard-disk space as virtual memory (also called the "swapfile" or "pagefile") to supplement RAM. The OS assigns some virtual-memory space to all processes, and the virtual memory itself gets used even if some RAM is still available. Accessing a hard disk is always slower than using RAM, so if your system has oodles of memory, you may improve performance slightly by telling Windows not to use the pagefile for some of its own code until it has used up available RAM. How much memory is in an oodle? That depends on the number and types of applications you typically run on your system--but don't make this adjustment unless your PC has at least 1GB of RAM.
        To make Windows use virtual memory only as a last resort, you have to edit the Windows Registry. And because anything can happen when you change your Registry, you must back it up first; see "Care and Feeding of the Windows Registry" for instructions. (Note that Microsoft recommends against eliminating your pagefile entirely.)
        With your Registry backup in place, choose Start, Run, type regedit, and press <Enter>. In the tree pane on the left, navigate to and select HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Session Manager\Memory Management. Double-click the Disable, Paging,Executive icon in the right pane. Change the '0' in the Value data box to 1, click OK, and restart your computer."
        Software For Metalworking


        • #5
          I think my "improvement" was illusory......

          After using the machine for some time, the floaty cursor came back.......

          It seems to be that it gradually, or at least incrementally, gets worse as the system is used.

          After a good boot, it is fine or acceptable for some time.

          Even with a number of windows active, it is still fine. But over time, a matter of an hour of work or so, it eventually dawns upon one that the problem is back.....

          Then the FIRST time a menu command in a program is used, it is slow and floaty. The SECOND time it is better, and the THIRD it is fine.

          If I select other commands in between, the problem remains unaffected.

          Only if I select the same operation several times in a row does it improve.

          So it seems to be fetching the "unused" code from some hole it has been poked into, if it hasn't been used for a couple minutes, or if something ELSE has been used.

          If it was recently used, it is available locally and is fast.....

          Or, alternately, something ELSE has to be fetched or stored away, in some manner that takes time and resources.

          Sounds like virtual memory, caching, or possibly DMA settings...., but I could easily be wrong in the diagnosis..... The behaviour I can vouch for.

          Whatever it is, the VERY SAME HARDWARE did NOT have the problem prior to XP.......................

          And, it still seems to take forever to shut down. Again, the longer it has been used, the longer it takes to shut down.

          About all I coud tell from the monitor program is that in windows, programs are busy as heck doing things, probably updating mouse position and hover selections...... I got 20 mB of log file from it in a matter of only a few minutes.

          Any particular items I should examine the log for?
          Last edited by J Tiers; 12-21-2006, 12:03 AM.

          Keep eye on ball.
          Hashim Khan


          • #6
            Open the task manager to the perfomance page just after booting. Take note of the "commit charge: total" value. Start opening and closing the various programs you are using and watch for the commit charge value to increase but not decrease equally when a program is terminated. Give it 10 or 15 seconds for the ram to be deallocated when the program is ended. If you find one that doesn't seem to deallocate the ram open it again and see if it grabs more ram each time. That's a memory leak.

            It may be necessary to give each program a workout to find this sort of problem. I can be caused by using only one specific function in a program. When I was tesing PSP9 I found a leak in the mesh warp routine. If you started using it and just played with it without closing it it would continuously eat more ram for the undo steps until it ran out and the system crashed.

            Another place that can grab and hold a lot of ram is the clipboard. If you copy and paste a large amount of data, say graphical data, it will stay there until replaced or cleared. Many programs will leave that data on the clipboard after closing. You can clear it by copying something very small to it.

            Failing to deallocate ram is probably the most common mistake that programmers make and it is often the undo buffer that is the culprit. In programs that have multi step undo functions it is frequently possible to specify the depth of the buffer in steps. If so, then set the buffer value to a reasonable number that suits your work style. Some programs give an option to hold the buffer in ram or disk. Try both to see if it makes a noticable difference. It usually will.
            Free software for calculating bolt circles and similar: Click Here


            • #7
              That's the reg hack I was thinking of! Sorry, should have been more informative on it.

              tons of reg hacks that will help speed up the system, some aren't approved for the corporate setting though.

              They aren't experimenting with a distributed processor set up are they?

              if you have remote desktop set up, are the techs peaking in to check operation, thereby causing the problem they're looking for?



              • #8
                OK, I had task manager running all day, and did most of my usual stuff....

                Didn't leak more than a little memory, if any........a few meg if that. Commit stayed below 30% of total known memory as a peak, i.e. 329 meg out of 1gig physical and 2.5 gig total..

                But the cursor got progressively more floaty during the day. Still isn't quite unusable, but it is noticeably more laggy than when it started.

                This one has me puzzled for sure.

                Keep eye on ball.
                Hashim Khan


                • #9
                  Originally posted by J Tiers
                  I think my "improvement" was illusory......

                  After using the machine for some time, the floaty cursor came back.......

                  When we had that problem at work it turned out to be cache memory was filling up and not dumping. We then found it better to power down the computers every time the floating cursor problem surfaced. It works for several days and then reboot again.
                  - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                  Thank you to our families of soldiers, many of whom have given so much more then the rest of us for the Freedom we enjoy.

                  It is true, there is nothing free about freedom, don't be so quick to give it away.


                  • #10
                    I don't recall if you said or not, does the cursor get "floaty" regardless of what app you are using?
                    Free software for calculating bolt circles and similar: Click Here


                    • #11
                      It does seem like a cache problem.

                      But it does not take days, I wish...... It only takes hours for it to get kinda stupid.

                      Machine gets turned off every night.

                      But, if it takes more than about 10 minutes to close itself down (not that unusual), I usually hit the switch.

                      Keep eye on ball.
                      Hashim Khan


                      • #12
                        This could be a very configuration dependent problem. Here is some info that may be relevant.

                        Free software for calculating bolt circles and similar: Click Here


                        • #13
                          Urk................ I just KNOW that article was helpful, but.......

                          "Da comp" has an IDE drive but since that seems to possibly LOOK like a SCSI, hmmm.....

                          In any case, I had the problem before setting to "no write cache" status, and it was unaffected by disabling write cacheing. Since it is disabled, the issue hopefully is a non-issue.

                          It's gonna stay disabled, because I am tired of my data (just generated) not being found by the graphing program section that wants output from the analysis portion....... That messes up graphs, and has cost me quite a bit of time.

                          Keep eye on ball.
                          Hashim Khan


                          • #14

                            Bought a few new games, and got some for Christmas, but some of them specifically call for XP, So I installed XP home, BIG mistake, I crash out of games that I used to play on a regular basis (C&C generals and Zero hour etc) My internet connection slows to a crawl for no reason whatever, and to top it off, the games that required XP aren't worth playing!

                            Been tweaking services, and doing a few reg hacks, got performance back up nearing 2k, but don't like the cartoonish interface either.

                            I had a slight issue with a floaty cursor, and it's gone now, so, along with the earler hack, here's a list of reg hacks I have done so far:

                            connecting to a remote computer XP/2k etc checks for scheduled tasks ~

                            Fortunately, deleting a couple of registry entries will disable this 'feature.'
                            To do this open REGEDIT and navigate to;
                            'HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Cur rentVersion\Explorer\RemoteComputer\NameSpace'

                            Delete the following sub-keys:
                            To disable Scheduled Task Checking delete:

                            To disable Printer Checking delete:


                            Dynamic Link Libraries, or DLLs, are files containing data or functions that Windows programs can call when needed by linking to them. Every piece of windows software will include instructions to the operating system as to which DLLs it will need to access, and XP will cache these particular files in memory for faster access.

                            The trouble is, Windows XP keeps these DLLs cached after the relevant program has closed, wasting memory space. While DLLs are generally tiny, enough of them can make a dent, so it's worthwhile to implement this registry tweak, which will force Windows XP to unload DLLs used by a specific program when that program halts.

                            To do this, first run REGEDIT.

                            Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Explorer.

                            reate a new key named 'AlwaysUnloadDLL' and set the default value to equal '1.'


                            If you have a lot of folders and subdirectories on your computer, when you access a directory XP wastes a lot of time updating the time stamp showing the last access time for that directory and for ALL sub directories. To stop XP doing this you need to edit the registry. If you are uncomfortable doing this then please do not attempt.

                            1. Go to Start and then Run and type “regedit”
                            2. Click through the file system until you get to “HKEY_LOCAL_MACHINE\System\CurrentControlSet\Contr ol\FileSystem”
                            3. Right-click in a blank area of the window on the right and select ‘DWORD Value’
                            4. Create a new DWORD Value called ‘NtfsDisableLastAccessUpdate’
                            5. Then Right click on the new value and select ‘Modify’
                            6. Change the Value Data to ‘1'
                            7. Click ‘OK’

                            These are cut and pastes from some site, don't remember which.

                            That last one realy sped up my computer, Have 6 hard drives broke down to between two and four partitions each, so have lots of folders etc on it. Wouldn't need the partitions if I went to ntfs, but hate that 'system volume information' folder you can't access, don't like anything hidden on my computer! Linux accesses it easily though.



                            • #15
                              Originally posted by J Tiers
                              It's gonna stay disabled, because I am tired of my data (just generated) not being found by the graphing program section that wants output from the analysis portion....... That messes up graphs, and has cost me quite a bit of time.
                              I've followed this a bit, but didn't really have anything to add beyond what others have said. But this statement bothers me. Write caching occurs at 2 levels. Within the process and within the OS file system. It seems that you’re talking of disabling write cache at the OS level. But that doesn’t match with your description. File system write caching should be completely transparent to ALL applications, just like memory address virtualization and many other features.

                              Write caching within a process is a different animal and happens within the file access libraries which attempt to optimize typical process behaviors where file output is generated incrementally right into the output stream. This can certainly affect other processes not being allowed to see completed results until the “file handle” is closed *OR* (and this is the important part) manually flushed to the file system. In this case, it is up to the programmer to manually flush/close when done specifically so another process can the read the results. If the programmer does not do that, then this is a bug in that program, not the OS.

                              How exactly are you “disabling write cache” behavior?
                              Master Floor Sweeper