Announcement

Collapse
No announcement yet.

Knocking in stepper motor?? cure

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Knocking in stepper motor?? cure

    I have been working on some deals here.. I bought several 250oz steppers off ebay, some more gecko drives.

    Mostly they been getting dusty. I was building a torch carrier for a flamecutter.. then I found I was short some 1/4" couplings.. so I tried to bore them into the ends of the acme rod.. wiggle and wobble visited my project so I pulled the plug on that.

    So, I had this old XY slide laying about with XL gear pulleys on it. (hold on I am getting there)

    I mounted the motors, still on thier plates on the slide.. Hooked the cables up to the geckos, set the current, rigged the opto22 breakout connections, cut up a "butch chewed" up USB cable, brought out the 5vdc (red+ black-} to the opto22 card.. then it works.. well.. it was sounding like someone was inside the lil motor knocking.. I was thinking, that can only be rust.. or a bad motor..(s) so I figured I had took it again in the rear on ebay..
    I had the scope on it, the meter, took the motor apart to see what was up.. nothing strange. NOW, I needed a triggered two input scope.. one trigger on the step line, other on the driveoutput.. but NO.. cheapskate bought the single input scope..

    BUT, hooking up the laptop and Mach3 instead of Turbocnc and Freedos.. No knock, more speed, faster.. smoother, I sure hate carrying that $1500 laptop down to the SHOP where I destroy about everything with grit and sparks.. (flamecutter?} I can remember toting laptops into dyehouses with waterhoses everywhere.

    Out comes the turbocnc computer.. I run a old Knoppix EMC version.. Smoother than Turbocnc, no knocking, Smoother than Mach3.. but it does not have as many bells and whistles..

    OKAY,, you got the history.. The knocking must be:

    (1) timing issues in the freedos and turbocnc
    (a: try it on real dos? 6.0)
    (b: try it on newer computer than a 500mhz celeron)
    (2) Gremlins and murphy's law?

    OK Which ?? anyone else had a problem like this?
    Excuse me, I farted.

  • #2
    In the config file:

    Set UsePentiumTimer=YES




    Free software for calculating bolt circles and similar: Click Here

    Comment


    • #3
      So far, this morning.. I installed Ubuntu Live Cd EMC install.. Then Mepis 6.0, then Freedos, then dos 6.0 (crashed) and then Windows 98SE crashed install..

      Now? XP says it has about 30 minutes to go.. Mepis works, but the Rtai timing driver buggered it up.

      So.. around and around I go.. Lets see what XP says..

      Simplest? EMC BDI rel 44.. installed but would not run on hard drive?????

      Runs steppers fine off cdrom.
      Excuse me, I farted.

      Comment


      • #4
        If nothing else today, I have learned that the new pc power supplies are crap. I was using the 5volt to drive a external pc104 board. I plugged it up and ZAPola.. Dead supply..

        The old At/XT supplies you could short, they'd smoke the wires and fill the house up with smoke. These new rascals, thou about 1/4th the size are nowhere near as durable.

        I got XP running on that antique 50mhz celeron, working actually pretty well.. It can run the other machines close by also without involving the laptop.

        I guess I am fixing to buy a new monitor, them LCd's at Walmart are $99. I will build a box around the motherboard, new supply, gecko rack drives and the monitor. I think I can get away with about 8-10 inches deep x15x15.. everything in one box and water tight. I might as well fix it right? HUH?
        Excuse me, I farted.

        Comment


        • #5
          I run TurboCNC and can confirm that it doesn't run well on all PCs.

          It is not so much the processor speed as the speed and consistency of the parallel port.

          This week I attempted to run TurboCNC with a 200 Mhz HP vectra. Previously this machine (lathe) had used a 90 Mhz box, and that ran fine until the box got zapped by lightning. So surely the 200 Mhz box would work, right?

          Wrong. Upon startup, the TCNC speed test gave a warning -- the average speed (I think he calls it latency time) was fine, but the max was out of spec. Sure enough, the motors ran like crap and skipped steps. I even tried disconnecting the motor from the drive and it still skipped steps, with zero load. I tried playing with the TCNC settings to no avail. I checked the DOS configuration, etc..

          Switched to another box (500 Mhz) and back to my original TCNC settings. Motors run smooth and strong. So apparently the one box was just not compatible with TCNC.

          I haven't tried the TCNC Pentium timer setting lately. Last I heard, that switch was not even being utilized by TCNC, but maybe I am out of date.

          Comment


          • #6
            Been quite a few upgrades since I downloaded the code and program too..

            I do have a turbo pascal 7 manual.. bought it at a bookstore.

            It was doing fine on Mach3.. Till I killed the computer.. It took me all day to go through all the installs of EMC.. to finally give up on running it on the hard drive.. they work on the cdrom.. but install them and it goes all to hell.

            Old junk... I sure miss the old Xt's.. they were rock solid.

            The toshiba laptop runs it pretty well.. considering it cost me $1500.. it should. It is 3.2 gig.

            Ahh heck.. ya can't win em all..
            Excuse me, I farted.

            Comment

            Working...
            X