Announcement

Collapse
No announcement yet.

Laser Welder Gloat

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    I took the computer back yesterday and put it back together. I could not get it to initialize the servos. Today I went back over and messed around with it some more and it started working. I think I had an IRQ error with the Mechatrolink II card that communicates with the servo drives. I managed to get it jogging but it is pretty out of tune. The X axis oscillated so much it broke the helical coupling. Luckily I have another at home that I machined to fit.

    I downloaded the latest yaskawa software to tune the drives, Ill give that I try, maybe tomorrow, I need to make some parts on the mill for a company and that kind of takes precedence.

    I had figured the software commanded the position of the drives through the Mechatrolink interface but it looks like it actually sends analog speed values to the drives and takes the encoder data and completes the loop in the PC. So it is a fully closed loop system.

    Comment


    • #47
      I ended up removing all the helical couplers and replacing them with bellows type. They are much stiffer torsionally and the flex was causing wind up which resulted in very unstable operatio. After replacing them the machine acted totally different. I used the Yaskawa software to set the inertia comp settings and to find the resonant freq. It takes that data and figures out the tuning parameters from that. Worked pretty well.

      Once I got the drives tuned to the machine I had to get the control software tuned to the drives. This was a pain in the rear. The software has a lot of parameters you can use but nothing that really said what applied to my drive system. When this version was released it was the first to support Mechatrolink and the set up data is rather incomplete. But after about 4-5 hours of messing with the parameters I finally got it tuned pretty well. The A axis may have to be redesigned. It is not very happy, tuning wise, the inertial mismatch is too big. I may have to use a gearbox to drive it. I will also have to retune the Z axis when I put the weld head back on. At this point I think I can reinstall the way covers, there should be nothing more to do under there.

      Couple pics, one of the old coupler and one of the new ones.


      IMG_2215 by macona, on Flickr


      IMG_2216 by macona, on Flickr

      Comment


      • #48
        Do you have link to a source for the bellows couplers?

        Comment


        • #49
          I used the DKN20 series couplers for this:

          http://www.rimteccorporation.com/pro...lows/index.htm

          You probably will want to be sitting down when you see the prices. I keep a stash of them and buy them when I find them cheap surplus.

          Ebay is a good place to get them too. I found some used ones I was going to buy if I couldnt bore the ones I had out to 14mm for the servo shaft. Even used they would have cost me $110 for 4.

          http://www.ebay.com/sch/i.html?_odkw...e&_sacat=12576

          Comment


          • #50
            The sign is amusing on your house, but actually necessary on the shop...
            Last edited by softboyled; 07-23-2013, 07:12 PM.

            Comment


            • #51
              It's a bloody amazing project, to say well done sounds patronising, defiantly out of the ball park
              Thanks for the ultrasonic link too, I,m trying fitting them to my parts washer!
              Regards
              Mark

              Comment


              • #52
                Well, bugger me, JK laser used to be 1/2 a mile away.mow they're 2 miles away from me. We've currently got two 5 axis Trumph lasers at work (transitioning from the old to the new...), but they aren't using local lasers
                Location- Rugby, Warwickshire. UK

                Comment


                • #53
                  Monday night I finally got the power supply moved over. Man, is that thing heavy. The lift gate was protesting.

                  Last night I wired and plumbed in the power supply. I need to fill it with distilled water next and I should be ready to see what happens.

                  Here is a pic of the power supply with the covers off. Top left is the "DC Chassis" It rectifies and filters power from the two main three phase transformers in the base of the supply. It also has the bleed resistors to drain the caps when it is shut down. Below that is the heat exchanger. It takes city water through a temperature control valve and passes it through a heat exchanger. The pump circulates water to the head first passing through carbon particulate and deionizing filters. Unlike many other arc lamp driven systems the electrodes are not immersed in water.

                  Top right is the circuit card rack. It has the logic for the power supply and handles the interfacing between the console/cnc and the power supply as well as controls the shutter and interlocks. Below that is the two flash lamp supplies, one supply per lamp. Each has twenty four 1000uf, 450v caps. A massive bipolar transistor controls the output to the lamps. The supply can control repetition rate, pulse length, and pulse intensity.

                  The two modules on the bottom on either side are the ignitors and simmer modules. The supply always keeps the lamp lit with a low current passing through. This makes firing more reliable and also makes it easier to time the flashes. Behind each modules is a 3 phase transformer, each one feeds on half of the DC Chassis.


                  Laser PowerSupply by macona, on Flickr

                  Comment


                  • #54
                    I took some distilled water over and filled it up. Hit the power button and ran into two problems. Leaky filter seal and the shaft seal on the pump leaks. It's a Lowara PB40/A pump that looks like was only sold in the UK. I think I found the shaft seal, only available in the UK, £60.90. Ouch...

                    Also found one of the transformer cooling fans is dead, no big deal on that one, there is a spare for it.

                    It does not leak too badly so I hit the power button for the power supply. I hear a click and nothing else happens. I start looking at the schematics and see I should have 48v for the main contactor and there is nothing. A bunch of tracing and I find a loose fuse holder on the power distribution board. They used an extra thick PCB and the leads on the fuse holders are not really long enough and the joint broke. I managed to shock the living hell out of myself finding this out. I am going to be sore in the morning.

                    Now I have 48v to the time delay relay on the DC Panel (Blue knob in above pic). The relay is not activating, it is just a snap on module on top of a more normal contactor. I disconnected it and popped it open, looked OK and then I noticed the plunger was stuck. I pulled on it a little bit and it popped loose and began to work normally. It had just sat too long and the rubber glued itself together. I proceeded to put it back together and hit the power button. The lights in the building flickered and the ready light came on. I hit the local button and the flash lamps started firing. I have not checked for emission yet.

                    A little video of it doing it's thing. The panel controls for pulse width and rate are not too happy. Might have to replace those as well.

                    Now I need to clean the collimator and the bend mirror and see if I have anything.

                    Comment


                    • #55
                      Last thursday I cleaned the optics and got the resonator lasing. I dont think the internal power meter is quite working right. I couldn't get the shutter to open, eventually figured out I need the doors closed on the cabinet to do that. Friday night I managed to set a paper towel on fire. Good progress.

                      I brought the push wheel switches home last night to repair them. They have a little plastic arm inside that acts as a spring to return the buttons after they have been pressed. Over the last couple decades these cracked and are no longer spring like. I stuck a soft piece of rubber in its place and that seems to work fine.

                      I took them back over today and reinstalled them. They work pretty good now. While I was there I decided to install the cutting head back on the Z slide. When I did this I found it was grossly out of line with the center line of beam. I spent the next hour realigning everything. It looks like this was the way it was when it came from the machine builders.

                      Got everything tuned in pretty well. I just cant get it to stabilize to a stop. The motors just dither, real annoying. I am getting pretty close to ditching this software and moving to LinuxCNC.

                      For fun I decided to see what it could do, I put a coke can in there and brought it into focus and fired away, here is the damage, not bad for old flash lamps and hammered cavity optics:


                      IMG_2258 by macona, on Flickr

                      Comment


                      • #56
                        Last monday I took the water pump apart to see what I could do about the mechanical seal, the only sources for the OEM seal are in the UK and at probably over $100 shipped I figured it was worth a try to see if I could find a replacement. It is a pretty standard seal, Aluminum oxide on one side, graphite on the other. 12mm shaft and a 26mm bore on the casing. I found a seal that matched these dimensions on Amazon for $6.20. What do you know it worked! I also changed the motor bearings while I was at it, they were pretty dry.

                        I knew the output coupler was pretty toast and I had never checked the high reflector. I found a new HR for an ESI laser that I had in one of my parts bins. Right diameter, wrong thickness. I took it over a couple nights ago to see if I could get it to fit. When I pulled out the old HR I found someone installed it backwards! OOPS! The new HR fit more or less and and I got 114w on my laser power meter. Not terrible, I guess. A new HR is about $300.

                        I have been put in touch with a company that works with Lumonics lasers and I am going to have then redo the coatings on the rod soon now that I know this beast works.

                        Comment


                        • #57
                          Macona, you get to play with some interesting stuff. By the way, I've found a much less expensive way to set paper on fire- something called matches.
                          I seldom do anything within the scope of logical reason and calculated cost/benefit, etc- I'm following my passion-

                          Comment


                          • #58
                            Originally posted by darryl View Post
                            Macona, you get to play with some interesting stuff. By the way, I've found a much less expensive way to set paper on fire- something called matches.
                            Sure, but they ain't near as much fun!
                            Definition: Racecar - a device that turns money into noise.

                            Comment


                            • #59
                              Ive been waiting on the guy at MDSI (OpenCNC) to help me get the darn servo loop tuned and have not heard anything from him. So at this point I am going to dump OpenCNC and go with LinuxCNC and use the internal positioning control that the drives have. This allows me to just send them step/dir signals like with a stepper motor. I am ordering a Mesa 5i25 with the 7i76 breakout today.

                              Found a nicer computer to replace the existing one with. It is a Advantech 19" industrial PCI/ISA backplane case with a PIII 933mhz SBC. 15" touchscreen with a membrane keybd and touchpad. Seems to work fine, with things tweaked it runs the latency app at about 21000 ns. Linux is fighting me with the monitor and the touchscreen. The monitor does not return EDID info so linux wont go past 800x600 no matter what, even after adding the modelines for it. I found a EDID emulator that goes in between the video card and display to give it the info it wants.

                              The touchscreen seems to just be a driver issue.


                              Advantech 19" rackmount by macona, on Flickr

                              Comment


                              • #60
                                I used to get some nice stuff from Tektronics Rams warehouse.
                                Are they still in business?

                                Comment

                                Working...
                                X