No announcement yet.

old Servo type 50.. how to disassemble?

  • Filter
  • Time
  • Show
Clear All
new posts

  • old Servo type 50.. how to disassemble?

    My Servo started acting wonky.. proving without a doubt 'if its not one thing, its another'.

    It engages fine, but the speed control doesn't work anymore.. either won't turn, or turns full speed which can be kinda exciting when it happens without warning.

    Gears are good. I've deluded myself into thinking it's only something minor.. nobody works on these anymore and replacement is expensive.

    I have the four screws off the bottom, and unit comes apart about .5" but no further. Seems like large bottom gear needs to come off next.. there's a small set screw behind the gear.. I can kinda access through one of the holes in the gear, but not enough to get it loose.

    Any trick to these?

  • #2
    I used to repair those at a place I worked. It's been a while so I may have the details wrong but if I recall correctly, once you have those screws out, the whole assembly, motor, controls, and all drop out the bottom. You should not need to remove the large gear at the bottom.

    Keep in mind that they pack a lot of stuff into a very small space in those things, so it may take some wiggling of the control handle and nudging to get it all out. It should not require any real forcing of things though. It sort of take 3 hands to get it all stuffed back in there, but it's not as bad as it looks at first.

    The ones I worked on were type 150's, so I could be well off base, but I'm pretty sure most of the models were overall very similar.

    From what you describe, I'd guess that the electronic speed control is bad. Sorry I can't be of more help.


    • #3
      Thanks alaganes... very helpful. I put some muscle into getting it apart, and you are correct.. gear did not need to come off. As said, getting the thing together again will be a chore.. nothing to lose!


      • #4
        Found the problem.. I think. Speed dial is connected via shaft with two flats on the end that are pressed into potentiometer. The shaft had come out and would kinda turn .. that would fit in with what how it was behaving. So got that fixed, and started re assembly.. went smooth except couldn't close it up last .25" or so... persuaded it. Plugged it in and nothing. Took it back apart and the remains of the brushes poured out (clumsy bastard). New brushes on way.. fingers crossed.
        Last edited by softtail; 11-02-2017, 03:54 PM.


        • #5
          Well hot damn, a couple of new brushes and the thing works. So much for obsolete. Beats $400 for a new import or 600+ for a Servo. This one looks like it's in very good shape. The original non self inflicted problem was that the shaft connecting the potentiometer to the knob had somehow worked loose. The light press fit of the bearings was what was keeping the whole unit from coming apart for me originally.


          • #6
            Nice work! I'd really like table feeds for my mill, maybe one day.

            They sure do pack a lot of stuff in that little box, don't they?

            Glad to hear you got it working and thanks for the follow-up.